const regex = /(^.?|(?!Miss)(^|.)(?!Mrs)(^|.)(?![MD]r).{2})\. *\b\w+\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.?|(?!Miss)(^|.)(?!Mrs)(^|.)(?![MD]r).{2})\\. *\\b\\w+\\b', 'gmi')
const str = `Mr. Foo
Mrs. bar
Hello Dr. Buzz
Testing Miss. Bloggs
Miss. Nomatch
This Mr. Does not Dr. Match Mrs. Test
This should. Match
Also. Match
. Match
A. Match
An. Match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}