using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0([1][89]|[2-9][0-9])";
string input = @"018 099 017 021 018 019 020 024 099 009999999";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}