re = /0([1][89]|[2-9][0-9])/
str = '018 099 017 021 018 019 020 024 099 009999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end