package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0([1][89]|[2-9][0-9])`)
var str = `018 099 017 021 018 019 020 024 099 009999999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}