package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:image:\/\/)(?<Thumnail>.+)\/transform\?size=thumb$`)
var str = `image://%2fhome%2fkeana%2fPictures%2fWallpapers%2fpawel-czerwinski-6lQDFGOB1iw-unsplash.jpg/transform?size=thumb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}