const regex = /(?:image:\/\/)(?<Thumnail>.+)\/transform\?size=thumb$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:image:\\\/\\\/)(?<Thumnail>.+)\\\/transform\\?size=thumb$', 'gm')
const str = `image://%2fhome%2fkeana%2fPictures%2fWallpapers%2fpawel-czerwinski-6lQDFGOB1iw-unsplash.jpg/transform?size=thumb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}