import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:image:\\/\\/)(?<Thumnail>.+)\\/transform\\?size=thumb$";
final String string = "image://%2fhome%2fkeana%2fPictures%2fWallpapers%2fpawel-czerwinski-6lQDFGOB1iw-unsplash.jpg/transform?size=thumb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}