# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(([^)(]*)\)(?=[^)(]*(?:\([^)(]*\)[^)(]*)*\))/$1/gm;t' <<< "Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
"