using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^)(]*)\)(?=[^)(]*(?:\([^)(]*\)[^)(]*)*\))";
string substitution = @"$1";
string input = @"Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}