const regex = /\(([^)(]*)\)(?=[^)(]*(?:\([^)(]*\)[^)(]*)*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([^)(]*)\\)(?=[^)(]*(?:\\([^)(]*\\)[^)(]*)*\\))', 'gm')
const str = `Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);