#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(([^)(]*)\)(?=[^)(]*(?:\([^)(]*\)[^)(]*)*\))"
Local $sString = "Record ID" & @CRLF & _
"What is the best food? (choice=Nachos)" & @CRLF & _
"What is the best food? (choice=Tacos (big bent nachos))" & @CRLF & _
"What is the best food? (choice=Chips with stuff) " & @CRLF & _
"Complete?" & @CRLF & _
"" & @CRLF & _
"So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)