#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^.*?(?:Lane|Street|Boulevard|Crescent|Place|Road|Highway|Avenue|Drive|Circuit|Parade|Telopea|Nicklin Way|Terrace|Square|Court|Close|Endeavour Way|Esplanade|East|The Centreway|Mall|Quay|Gateway|Low Way|Point|Rd|Morinda|Way|Ave|St|South Steyne|Broadway|HQ|Expressway|Street|Castlereagh|Meadow Way|Track|Kulkyne Way|Narabang Way|Bank)),(?:)? ?(.*?),? ?([A-Z]{2,3}),? ?(\d{,4})$"
Local $sString = "139 McKinnon Road, PINELANDS, NT, 829" & @CRLF & _
"108 East Point Road, Fannie Bay, NT, 820" & @CRLF & _
"3-11 Hamilton Street, Townsville City, QLD, 4810" & @CRLF & _
"40 17 Geranium Street, THE GARDENS, NT, 820" & @CRLF & _
"1, 3, 5 Demeter Street & 12 Hermes Avenue ROUSE HILL NSW 2155" & @CRLF & _
"Lot 9 Island Point Road, ST GEORGES BASIN, NSW, 2540" & @CRLF & _
"31 Stephen Street SOUTH TOOWOOMBA QLD 4350" & @CRLF & _
"316 Sturt Street and 511 Flinders Street, Townsville City, QLD, 4810"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")