# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*?(?:Lane|Street|Boulevard|Crescent|Place|Road|Highway|Avenue|Drive|Circuit|Parade|Telopea|Nicklin Way|Terrace|Square|Court|Close|Endeavour Way|Esplanade|East|The Centreway|Mall|Quay|Gateway|Low Way|Point|Rd|Morinda|Way|Ave|St|South Steyne|Broadway|HQ|Expressway|Street|Castlereagh|Meadow Way|Track|Kulkyne Way|Narabang Way|Bank)),(?:)? ?(.*?),? ?([A-Z]{2,3}),? ?(\d{,4})$"
test_str = ("139 McKinnon Road, PINELANDS, NT, 829\n"
"108 East Point Road, Fannie Bay, NT, 820\n"
"3-11 Hamilton Street, Townsville City, QLD, 4810\n"
"40 17 Geranium Street, THE GARDENS, NT, 820\n"
"1, 3, 5 Demeter Street & 12 Hermes Avenue ROUSE HILL NSW 2155\n"
"Lot 9 Island Point Road, ST GEORGES BASIN, NSW, 2540\n"
"31 Stephen Street SOUTH TOOWOOMBA QLD 4350\n"
"316 Sturt Street and 511 Flinders Street, Townsville City, QLD, 4810")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.