import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*?(?:Lane|Street|Boulevard|Crescent|Place|Road|Highway|Avenue|Drive|Circuit|Parade|Telopea|Nicklin Way|Terrace|Square|Court|Close|Endeavour Way|Esplanade|East|The Centreway|Mall|Quay|Gateway|Low Way|Point|Rd|Morinda|Way|Ave|St|South Steyne|Broadway|HQ|Expressway|Street|Castlereagh|Meadow Way|Track|Kulkyne Way|Narabang Way|Bank)),(?:)? ?(.*?),? ?([A-Z]{2,3}),? ?(\\d\\{,4\\})$";
final String string = "139 McKinnon Road, PINELANDS, NT, 829\n"
+ "108 East Point Road, Fannie Bay, NT, 820\n"
+ "3-11 Hamilton Street, Townsville City, QLD, 4810\n"
+ "40 17 Geranium Street, THE GARDENS, NT, 820\n"
+ "1, 3, 5 Demeter Street & 12 Hermes Avenue ROUSE HILL NSW 2155\n"
+ "Lot 9 Island Point Road, ST GEORGES BASIN, NSW, 2540\n"
+ "31 Stephen Street SOUTH TOOWOOMBA QLD 4350\n"
+ "316 Sturt Street and 511 Flinders Street, Townsville City, QLD, 4810";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}