package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.*?(?:Lane|Street|Boulevard|Crescent|Place|Road|Highway|Avenue|Drive|Circuit|Parade|Telopea|Nicklin Way|Terrace|Square|Court|Close|Endeavour Way|Esplanade|East|The Centreway|Mall|Quay|Gateway|Low Way|Point|Rd|Morinda|Way|Ave|St|South Steyne|Broadway|HQ|Expressway|Street|Castlereagh|Meadow Way|Track|Kulkyne Way|Narabang Way|Bank)),(?:)? ?(.*?),? ?([A-Z]{2,3}),? ?(\d{,4})$`)
var str = `139 McKinnon Road, PINELANDS, NT, 829
108 East Point Road, Fannie Bay, NT, 820
3-11 Hamilton Street, Townsville City, QLD, 4810
40 17 Geranium Street, THE GARDENS, NT, 820
1, 3, 5 Demeter Street & 12 Hermes Avenue ROUSE HILL NSW 2155
Lot 9 Island Point Road, ST GEORGES BASIN, NSW, 2540
31 Stephen Street SOUTH TOOWOOMBA QLD 4350
316 Sturt Street and 511 Flinders Street, Townsville City, QLD, 4810`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}