#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=twitter.com\/)[^?\s]+"
Local $sString = "https://twitter.com/test1" & @CRLF & _
"" & @CRLF & _
"http://twitter.com/test2" & @CRLF & _
"" & @CRLF & _
"https://www.twitter.com/test3?" & @CRLF & _
"" & @CRLF & _
"https://www.mobile.twitter.com/test4" & @CRLF & _
"" & @CRLF & _
"https://www.twitter.com/test5?lang=en" & @CRLF & _
"" & @CRLF & _
"https://www.instagram.com/test1insta"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")