re = /(?<=twitter.com\/)[^?\s]+/m
str = 'https://twitter.com/test1
http://twitter.com/test2
https://www.twitter.com/test3?
https://www.mobile.twitter.com/test4
https://www.twitter.com/test5?lang=en
https://www.instagram.com/test1insta'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end