import re
regex = re.compile(r"(?<=twitter.com\/)[^?\s]+", flags=re.MULTILINE)
test_str = ("https://twitter.com/test1\n\n"
"http://twitter.com/test2\n\n"
"https://www.twitter.com/test3?\n\n"
"https://www.mobile.twitter.com/test4\n\n"
"https://www.twitter.com/test5?lang=en\n\n"
"https://www.instagram.com/test1insta")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")