import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=twitter.com\\/)[^?\\s]+";
final String string = "https://twitter.com/test1\n\n"
+ "http://twitter.com/test2\n\n"
+ "https://www.twitter.com/test3?\n\n"
+ "https://www.mobile.twitter.com/test4\n\n"
+ "https://www.twitter.com/test5?lang=en\n\n"
+ "https://www.instagram.com/test1insta";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}