#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}"
Local $sString = "37.148.183.244" & @CRLF & _
"91.230.178.112" & @CRLF & _
"91.230.178.10" & @CRLF & _
"91.230.179.64" & @CRLF & _
"185.194.84.26" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")