import re
regex = re.compile(r"\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}", flags=re.MULTILINE)
test_str = ("37.148.183.244\n"
"91.230.178.112\n"
"91.230.178.10\n"
"91.230.179.64\n"
"185.194.84.26\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")