using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}";
string input = @"37.148.183.244
91.230.178.112
91.230.178.10
91.230.179.64
185.194.84.26
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}