re = /\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}/m
str = '37.148.183.244
91.230.178.112
91.230.178.10
91.230.179.64
185.194.84.26
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end