#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?=\sis)|(?<=is\s)\d+\.?$"
Local $sString = "Time: 02:30 PM Your OTP is 3242." & @CRLF & _
"12345 is your OTP. TIME: 04:45 AM." & @CRLF & _
"Your otp for account 123456789 is 4565"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")