import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?=\\sis)|(?<=is\\s)\\d+\\.?$";
final String string = "Time: 02:30 PM Your OTP is 3242.\n"
+ "12345 is your OTP. TIME: 04:45 AM.\n"
+ "Your otp for account 123456789 is 4565";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}