$re = '/^\d+(?=\sis)|(?<=is\s)\d+\.?$/m';
$str = 'Time: 02:30 PM Your OTP is 3242.
12345 is your OTP. TIME: 04:45 AM.
Your otp for account 123456789 is 4565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);