import re
regex = re.compile(r"^\d+(?=\sis)|(?<=is\s)\d+\.?$", flags=re.MULTILINE)
test_str = ("Time: 02:30 PM Your OTP is 3242.\n"
"12345 is your OTP. TIME: 04:45 AM.\n"
"Your otp for account 123456789 is 4565")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")