import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^|^\\d{2}-)\\d{3,})-(\\d+-)*(\\w+)(?=-(ZE|KBR)-)";
final String string = "437401-762-ZE-9-52-9.xml\n"
+ "02-419892-0-9743-KBR-2503-1-1.xml\n"
+ "437401-BREIT-ZE-1-1-1.xml\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}