re = /((^|^\d{2}-)\d{3,})-(\d+-)*(\w+)(?=-(ZE|KBR)-)/m
str = '437401-762-ZE-9-52-9.xml
02-419892-0-9743-KBR-2503-1-1.xml
437401-BREIT-ZE-1-1-1.xml
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end