const regex = /((^|^\d{2}-)\d{3,})-(\d+-)*(\w+)(?=-(ZE|KBR)-)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^|^\\d{2}-)\\d{3,})-(\\d+-)*(\\w+)(?=-(ZE|KBR)-)', 'gm')
const str = `437401-762-ZE-9-52-9.xml
02-419892-0-9743-KBR-2503-1-1.xml
437401-BREIT-ZE-1-1-1.xml
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}