import re
regex = re.compile(r"((^|^\d{2}-)\d{3,})-(\d+-)*(\w+)(?=-(ZE|KBR)-)", flags=re.MULTILINE)
test_str = ("437401-762-ZE-9-52-9.xml\n"
"02-419892-0-9743-KBR-2503-1-1.xml\n"
"437401-BREIT-ZE-1-1-1.xml\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")