# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\S+)(?:\s+\1\b)+/$1/gi;t' <<< "A very very very dirty dog Dog"