use strict;
my $str = 'A very very very dirty dog Dog';
my $regex = qr/\b(\S+)(?:\s+\1\b)+/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";