re = /\b(\S+)(?:\s+\1\b)+/i
str = 'A very very very dirty dog Dog'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result