const regex = /"(field)"(\s*:\s*")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(field)"(\\s*:\\s*")', 'gm')
const str = `"field": {}
"field" : ""
"field":1`;
const subst = `"$1_text"$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);