using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9a-z-]{36}$";
string input = @"ce91ffbe-8218-e211-86da-000c29e211a0
ce91ffbe-8218-e211-86da-000c29e211a
ce91ffbe-8218-e211-86da-000c29e211a0a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}