// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9a-z-]{36}$").unwrap();
let string = "ce91ffbe-8218-e211-86da-000c29e211a0
ce91ffbe-8218-e211-86da-000c29e211a
ce91ffbe-8218-e211-86da-000c29e211a0a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}