$re = '/^[0-9a-z-]{36}$/m';
$str = 'ce91ffbe-8218-e211-86da-000c29e211a0
ce91ffbe-8218-e211-86da-000c29e211a
ce91ffbe-8218-e211-86da-000c29e211a0a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);