import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9a-z-]{36}$";
final String string = "ce91ffbe-8218-e211-86da-000c29e211a0\n"
+ "ce91ffbe-8218-e211-86da-000c29e211a\n"
+ "ce91ffbe-8218-e211-86da-000c29e211a0a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}