#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([A-Z]*[a-z]+)(\d+)?([A-Z][a-z]+)\b"
Local $sString = "AdobeSoftware should be "Adobe" and "Software"" & @CRLF & _
"adobeSoftware should be "adobe" and "Software"" & @CRLF & _
"ADobeSoftware should be "ADobe" and "Software"" & @CRLF & _
"adobe1Software should be "adobe" and "1" and "Software""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")