package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([A-Z]*[a-z]+)(\d+)?([A-Z][a-z]+)\b`)
var str = `AdobeSoftware should be "Adobe" and "Software"
adobeSoftware should be "adobe" and "Software"
ADobeSoftware should be "ADobe" and "Software"
adobe1Software should be "adobe" and "1" and "Software"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}