re = /\b([A-Z]*[a-z]+)(\d+)?([A-Z][a-z]+)\b/m
str = 'AdobeSoftware should be "Adobe" and "Software"
adobeSoftware should be "adobe" and "Software"
ADobeSoftware should be "ADobe" and "Software"
adobe1Software should be "adobe" and "1" and "Software"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end