using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-Z]*[a-z]+)(\d+)?([A-Z][a-z]+)\b";
string input = @"AdobeSoftware should be ""Adobe"" and ""Software""
adobeSoftware should be ""adobe"" and ""Software""
ADobeSoftware should be ""ADobe"" and ""Software""
adobe1Software should be ""adobe"" and ""1"" and ""Software""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}