import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(.+?)(?: (.+?)=(.+?))*?>.*?<\\/\\1>";
final String string = "<w c5=\"NP0\" hw=\"michael\" pos=\"SUBST\">Michael </w>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}