import re
regex = re.compile(r"<(.+?)(?: (.+?)=(.+?))*?>.*?<\/\1>", flags=re.MULTILINE)
test_str = "<w c5=\"NP0\" hw=\"michael\" pos=\"SUBST\">Michael </w>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)