import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SessionStartTime=(?<date>[^|]*)\\|LogEventId=(?<LogEventId>[^|]*)\\|action=(?<action>[^|]*)\\|login=(?<login>[^|]*)\\|account=(?<tag1>[^|]*)\\|sip=(?<sip>[^|]*)\\|UserName=(?<tag2>[^|]*)\\|group=(?<group>[^|]*)\\|responsecode=(?<responsecode>[^|]*)\\|result=(?<result>[^|]*)\\|dname=(?<dname>[^|]*)\\|sessiontype=(?<sessiontype>[^|]*)\\|(?<vendorinfo>[^ ]*)$";
final String string = "SessionStartTime=2/21/2021 6:36:37 PM|LogEventId=1898|action=Successful login with database selected|login=1191180|account=RUBRI1|sip=192.168.0.22|UserName=Rick Rubner|group=3|responsecode=0|result=|dname=USDF11V0835\\LTEPICPR|sessiontype=|vendorinfo=LTEPIC\n\n"
+ "\\|\\s+(?<sip>[^ ]*)\\s+\\|\\s+(?<login>[^ ]*)\\s+\\|\\s+(?<action>[^|]*)\\s+\\|\\s+(?<vendorinfo>[^ ]*)$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}