re = /SessionStartTime=(?<date>[^|]*)\|LogEventId=(?<LogEventId>[^|]*)\|action=(?<action>[^|]*)\|login=(?<login>[^|]*)\|account=(?<tag1>[^|]*)\|sip=(?<sip>[^|]*)\|UserName=(?<tag2>[^|]*)\|group=(?<group>[^|]*)\|responsecode=(?<responsecode>[^|]*)\|result=(?<result>[^|]*)\|dname=(?<dname>[^|]*)\|sessiontype=(?<sessiontype>[^|]*)\|(?<vendorinfo>[^ ]*)$/mix
str = 'SessionStartTime=2/21/2021 6:36:37 PM|LogEventId=1898|action=Successful login with database selected|login=1191180|account=RUBRI1|sip=192.168.0.22|UserName=Rick Rubner|group=3|responsecode=0|result=|dname=USDF11V0835\\LTEPICPR|sessiontype=|vendorinfo=LTEPIC
\\|\\s+(?<sip>[^ ]*)\\s+\\|\\s+(?<login>[^ ]*)\\s+\\|\\s+(?<action>[^|]*)\\s+\\|\\s+(?<vendorinfo>[^ ]*)$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end