// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)SessionStartTime=(?<date>[^|]*)\|LogEventId=(?<LogEventId>[^|]*)\|action=(?<action>[^|]*)\|login=(?<login>[^|]*)\|account=(?<tag1>[^|]*)\|sip=(?<sip>[^|]*)\|UserName=(?<tag2>[^|]*)\|group=(?<group>[^|]*)\|responsecode=(?<responsecode>[^|]*)\|result=(?<result>[^|]*)\|dname=(?<dname>[^|]*)\|sessiontype=(?<sessiontype>[^|]*)\|(?<vendorinfo>[^ ]*)$").unwrap();
let string = "SessionStartTime=2/21/2021 6:36:37 PM|LogEventId=1898|action=Successful login with database selected|login=1191180|account=RUBRI1|sip=192.168.0.22|UserName=Rick Rubner|group=3|responsecode=0|result=|dname=USDF11V0835\\LTEPICPR|sessiontype=|vendorinfo=LTEPIC
\\|\\s+(?<sip>[^ ]*)\\s+\\|\\s+(?<login>[^ ]*)\\s+\\|\\s+(?<action>[^|]*)\\s+\\|\\s+(?<vendorinfo>[^ ]*)$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}