package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^()\n]*)\(([^()\n]*)\)(.*)$`)
var str = `flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}