// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^()\n]*)\(([^()\n]*)\)(.*)$").unwrap();
let string = "flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}